summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Ivanov2022-07-23 20:44:39 +0300
committerKonstantin Ivanov2022-07-23 20:44:39 +0300
commita91c0a2c3e28f1c72341551b78d3091a61aee9ec (patch)
treea97c9350f21ff8b18d89b00e3ab4a7c7321f5c41 /PKGBUILD
downloadaur-a91c0a2c3e28f1c72341551b78d3091a61aee9ec.tar.gz
bumn first version on 52192368063cbc676c15006c539367c7375704aa commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d38302c802ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=yaknewtab
+commit_hash=52192368063cbc676c15006c539367c7375704aa
+pkgver=${commit_hash}
+pkgrel=1
+pkgdesc='A shell script for opening new Yakuake tabs/sessions'
+arch=(any)
+url='https://github.com/RogueScholar/yaknewtab'
+license=(GPL-3.0)
+
+depends=(
+ 'bash'
+)
+
+makedepends=(
+ 'coreutils'
+)
+
+source=(https://github.com/RogueScholar/yaknewtab/archive/${pkgver}.tar.gz)
+sha256sums=('298431e08bd9179c082fd7b9b2d81cae41e57f6b6b07fee62a9b6f0b54afcc9d')
+
+provides=(yaknewtab)
+
+package() {
+ cd "yaknewtab-${pkgver}"
+ install -Dp --mode=755 --owner=root --group=root yaknewtab /usr/local/bin/yaknewtab
+}