summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-07-30 15:03:25 +1200
committercaltlgin2020-07-30 15:03:25 +1200
commit758b2314f4f69d069ea2198d1c39c25960247901 (patch)
tree1bd950e9412fbad033e645b1bf27b894931b39e7 /PKGBUILD
parentb36272e7a42279c9cb981ae8e61296a73565d170 (diff)
downloadaur-758b2314f4f69d069ea2198d1c39c25960247901.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 21 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 634c8b511f89..c663eb6df85d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,33 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
-pkgname=yakuake-git
-pkgver=v3.0.2.6.g87f7321
+_pkgname=yakuake
+pkgname=${_pkgname}-git
+pkgver=20.04.2.r40.g946ecc7
pkgrel=1
-pkgdesc="A drop-down terminal emulator based on KDE Konsole technology. (GIT version)"
-arch=('i686' 'x86_64')
-url='https://www.kde.org/applications/system/yakuake'
-license=('GPL')
-depends=('knewstuff'
- 'konsole'
- 'kwayland'
- 'hicolor-icon-theme'
- )
-makedepends=('extra-cmake-modules'
- 'git'
- 'python'
- )
-conflicts=('yakuake')
-provides=('yakuake')
-source=('git://anongit.kde.org/yakuake.git')
-sha1sums=('SKIP')
+pkgdesc='A drop-down terminal emulator based on KDE konsole technology'
+arch=('x86_64')
+url='https://kde.org/applications/system/org.kde.yakuake'
+license=('GPL2')
+groups=('kde-applications' 'kde-utilities')
+depends=('hicolor-icon-theme' 'konsole' 'kwayland')
+makedepends=('extra-cmake-modules' 'git')
+provides=("${_pkgname}")
+source=("git+https://invent.kde.org/utilities/${_pkgname}.git")
+sha256sums=('SKIP')
pkgver() {
- cd yakuake
- echo "$(git describe --long --tags | tr - .)"
-}
-
-prepare() {
- mkdir -p build
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd build
- cmake ../yakuake \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ cmake -B build -S "${_pkgname}" \
-DBUILD_TESTING=OFF
- make
+ cmake --build build
}
package() {
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
}
+
+# vim: ts=2 sw=2 et: