summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitrios Misdanitis2016-09-27 20:09:12 +0100
committerDimitrios Misdanitis2016-09-27 20:09:12 +0100
commit2e3885329776288b758bb14c926b595817640cda (patch)
treee7e31fa7a7418fc8c95ae96af279b3ae3d5aa17a /PKGBUILD
downloadaur-2e3885329776288b758bb14c926b595817640cda.tar.gz
created basic PKGBUILD to download yakuake from KDE repo and apply the focus patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6848e2ae8c09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Dimitrios Misdanitis <d.misdanitis@gmail.com>
+
+pkgname=yakuake-sp-git
+pkgver=v3.0.2.7.g2c081e7.focusfix
+pkgrel=1
+pkgdesc="A drop-down terminal emulator based on KDE Konsole technology. (GIT version with split focus patch)"
+arch=('i686' 'x86_64')
+url='https://www.kde.org/applications/system/yakuake'
+license=('GPL')
+depends=('knewstuff'
+ 'konsole'
+ 'kwayland'
+ 'hicolor-icon-theme'
+ )
+makedepends=('extra-cmake-modules'
+ 'git'
+ 'python'
+ )
+conflicts=('yakuake')
+provides=('yakuake')
+source=('git://anongit.kde.org/yakuake.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd yakuake
+ echo "$(git describe --long --tags | tr - .).focusfix"
+}
+
+prepare() {
+ cd ${srcdir}/yakuake
+ patch -p1 <../../0001-focus-fix.patch
+ cd ${srcdir}
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../yakuake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}