summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2021-07-06 02:31:22 +0200
committerCarsten Teibes2021-07-06 02:31:22 +0200
commit0a5fc8fc7f956c84710b76cd12d63cc4bdbc6361 (patch)
tree32757497521fbff82eec5d898cf5f7c34d99fc8e /PKGBUILD
parent2447f72d2432281b98377cb47f64770fe674e98c (diff)
downloadaur-yamagi-quake2-xatrix-git.tar.gz
[upd] back to using the Makefile, small cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29b787dd3ee0..68801fd7e3da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=yamagi-quake2-xatrix-git
-pkgver=2.06.r0.g1d6e3f6
+pkgver=2.09.r1.g15791dc
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Mission Pack 1 ('The Reckoning') for yamagi-quake2 (development version)"
-url="http://www.yamagi.org/quake2/"
+url="https://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
-makedepends=('cmake' 'ninja')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install=${pkgname%-*}.install
@@ -25,27 +24,25 @@ pkgver() {
}
build() {
- rm -rf build
- cmake ${pkgname%-*} -Bbuild \
- -DCMAKE_BUILD_TYPE=Release \
- -GNinja
- cmake --build build
+ make -C ${pkgname%-*}
}
package() {
- # game library
- install -Dm644 build/Release/game.so "$pkgdir"/usr/lib/yamagi-quake2/xatrix/game.so
+ local pkg=${pkgname%-*}
- cd ${pkgname%-*}
+ cd $pkg
+
+ # game library
+ install -Dm644 -t "$pkgdir"/usr/lib/yamagi-quake2/xatrix release/game.so
# game launcher
- install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
+ install -Dm755 ../$pkg.sh "$pkgdir"/usr/bin/$pkg
# doc
- install -Dm644 README "$pkgdir"/usr/share/doc/${pkgname%-*}/README
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkg README
# desktop entry
- install -Dm644 ../${pkgname%-*}.desktop "$pkgdir"/usr/share/applications/${pkgname%-*}.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/applications ../$pkg.desktop
# license
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE