summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2017-07-05 22:28:51 +0200
committerCarsten Teibes2017-07-05 22:28:51 +0200
commit361453baa27a017b6a6f4a363f52125d94e21e0a (patch)
tree3b9183076394b50f61d281ea013287b9a84696b1 /PKGBUILD
parent549cb08e1721efd9d9825aab00798431143937ce (diff)
downloadaur-361453baa27a017b6a6f4a363f52125d94e21e0a.tar.gz
[upd] use cmake, [fix] game library path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 075bdeeeafeb..a4f7c8cf6e01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=yamagi-quake2-xatrix-git
-pkgver=2.01.r3.g150c521
+pkgver=2.05.r1.g99a032c
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Mission Pack 1 ('The Reckoning') for yamagi-quake2 (development version)"
url="http://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
+makedepends=('cmake')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install=${pkgname%-*}.install
@@ -23,19 +24,26 @@ pkgver() {
git describe --long --tags | sed 's/^XATRIX_//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ rm -rf build
+ mkdir -p build
+}
+
build() {
- make -C ${pkgname%-*}
+ cd build
+ cmake ../${pkgname%-*} -DCMAKE_BUILD_TYPE=Release
+ make
}
package() {
+ # game library
+ install -Dm644 build/Release/game.so "$pkgdir"/usr/lib/yamagi-quake2/xatrix/game.so
+
cd ${pkgname%-*}
# game launcher
install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
- # game library
- install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/xatrix/game.so
-
# doc
install -Dm644 README "$pkgdir"/usr/share/doc/${pkgname%-*}/README