summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMax Gautier2023-07-21 06:53:46 +0200
committerMax Gautier2023-07-21 06:53:46 +0200
commit6bb10e525c6c673195f0b5c76b76140518529a14 (patch)
tree89e29338cc2a34246109622ba5058e2a43e49959 /PKGBUILD
parente0d455fda05a1671698ea0575e4e97a4066d0344 (diff)
downloadaur-6bb10e525c6c673195f0b5c76b76140518529a14.tar.gz
Update version + switch to git source and gpg validation of source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e72dd15eae3..c946a9856cfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,16 @@
pkgname=yambar-wayland
_pkgname=yambar
-pkgver=1.9.0
+pkgver=1.10.0
pkgrel=5
pkgdesc="Simplistic and highly configurable status panel for Wayland (No X11 support)"
arch=('any')
-url=https://codeberg.org/dnkl/yambar
+url=https://codeberg.org/dnkl/$_pkgname
license=('MIT')
conflicts=('yambar')
provides=('yambar')
makedepends=(
+ 'git'
'wayland-protocols'
'meson'
'ninja'
@@ -35,8 +36,9 @@ optdepends=(
'libmpdclient: for the MPD module')
checkdepends=(
'libmpdclient')
-source=("${pkgname}-${pkgver}.tar.gz::https://codeberg.org/dnkl/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('46f3002338f451c154678167bf3d5f593307954b6f381c50ddef2726b1a8c811')
+source=("git+$url.git?signed#commit=c4e094de3e531675bae9ff76d7e6f0dfdcaecae9")
+sha256sums=('SKIP')
+validpgpkeys=('B19964FBBA09664CC81027ED5BBD4992C116573F') # Daniel Eklöf (Git signing) <daniel@ekloef.se>
build() {
cd $_pkgname