summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhirui Dai2023-08-14 19:43:12 -0700
committerZhirui Dai2023-08-14 19:43:12 -0700
commit23d7d417673e4fb2c0b4655840e2325b85efbdb1 (patch)
treec82a64a43e76e2a1d9d5b9afe0e34a3c45044c1b /PKGBUILD
parentad2587ca0a3b5db2a835a99443bcec742c3cc782 (diff)
downloadaur-23d7d417673e4fb2c0b4655840e2325b85efbdb1.tar.gz
update PKGBUILD to fix installation error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8606fb5c424..3747cb2d071d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Original authors: Sven-Hendrik Haase <sh@lutzhaase.com>, Markus Martin <markus@archwyrm.net>
pkgname=yaml-cpp-git
-pkgver=r684.e92321a
+pkgver=r937.f732014
pkgrel=1
pkgdesc="YAML parser and emitter in C++, written around the YAML 1.2 spec"
url="https://github.com/jbeder/yaml-cpp"
@@ -11,7 +11,7 @@ license=('MIT')
depends=('gcc-libs')
conflicts=('yaml-cpp')
provides=('yaml-cpp')
-makedepends=('boost' 'cmake')
+makedepends=('boost' 'cmake' 'git')
source=(${pkgname}::git+https://github.com/jbeder/yaml-cpp.git)
md5sums=('SKIP')
@@ -21,20 +21,11 @@ pkgver() {
}
build() {
- cd $srcdir/$pkgname
-
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON
- make
+ cd $srcdir
+ cmake -B build -S $pkgname -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -DCMAKE_BUILD_TYPE=Release -DYAML_CPP_INSTALL=ON
+ cmake --build build -- -j$(nproc)
}
package() {
- cd $srcdir/$pkgname
-
- make DESTDIR=$pkgdir install
-
- install -Dm644 yaml-cpp-config.cmake $pkgdir/usr/lib/cmake/${pkgname}/yaml-cpp-config.cmake
- install -Dm644 yaml-cpp-config-version.cmake $pkgdir/usr/lib/cmake/${pkgname}/yaml-cpp-config-version.cmake
- install -Dm644 yaml-cpp-targets.cmake $pkgdir/usr/lib/cmake/${pkgname}/yaml-cpp-targets.cmake
-
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ DESTDIR="$pkgdir" cmake --install build
}