summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStalker-medik2019-06-24 17:32:29 +0300
committerStalker-medik2019-06-24 17:32:29 +0300
commit23e51b0441829cd467221e7e70d7b9830e335432 (patch)
tree70b9e18da3fd96c4e42977d39931b31d15591e0e /PKGBUILD
parent582541f71b316f36c91041f24364570381ac9be8 (diff)
downloadaur-23e51b0441829cd467221e7e70d7b9830e335432.tar.gz
Set correct PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1aad9f0a4304..c19d98c11e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,23 @@
pkgname='yandex-disk-indicator'
pkgver=1.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="Panel indicator (GUI) for YandexDisk CLI client for Linux."
arch=('i686' 'x86_64')
url="https://github.com/slytomcat/${pkgname}/"
license=('GPL3')
depends=('yandex-disk' 'python' 'python-pyinotify' 'pygobject-devel' 'python-gobject' 'libappindicator-gtk3' 'xclip' 'zenity')
-source=("$pkgname::git+https://github.com/slytomcat/${pkgname}.git")
-sha1sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=("https://github.com/slytomcat/yandex-disk-indicator/archive/${pkgver}.tar.gz")
+sha256sums=('351253b2a06177b235009d2338d43c8f7884032d363ac9d48a496c828fbb58c8')
prepare() {
- cd $pkgname/build
- chmod +x prepare.sh
+ cd "${pkgname}-${pkgver}/build"
+ chmod +x prepare.sh
}
package() {
- mkdir $pkgdir/usr
- cd $pkgname/build
+ mkdir "${pkgdir}/usr"
+ cd "${pkgname}-${pkgver}/build"
export TARGET="$pkgdir/usr"
sh prepare.sh
}