summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Keen2015-06-23 15:17:59 -0400
committerKyle Keen2015-06-23 15:17:59 -0400
commitf981aa4c5a26a4585059e8d98b24c99d9e7e5ea8 (patch)
tree83556f1e3fc49387fe4576c0ac8c9db661f777e8 /PKGBUILD
downloadaur-f981aa4c5a26a4585059e8d98b24c99d9e7e5ea8.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d79b91473c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Leonidas <marek@xivilization.net>
+
+pkgname=yap
+pkgver=6.2.2
+pkgrel=5
+pkgdesc='A high-performance Prolog compiler'
+url='http://www.dcc.fc.up.pt/~vsc/Yap/'
+license=('PerlArtistic')
+arch=('i686' 'x86_64')
+depends=('gmp' 'unixodbc' 'libmariadbclient')
+#makedepends=('texi2html' 'texinfo' 'jdk7-openjdk' 'texlive-plainextra')
+#optdepends=('java-runtime-headless: Java Interface Library JPL')
+source=("http://www.dcc.fc.up.pt/~vsc/Yap/${pkgname}-${pkgver}.tar.gz"
+ "friend-function.patch")
+md5sums=('95eaa54978e4811ff6e504e7dca9e835'
+ '5b5884a62e8cd9482408565576b872f8')
+
+# issues building java bindings and info pages?
+# I leave those up to you to fix, dear reader
+
+# gcc 5 patch
+# http://pkgs.fedoraproject.org/cgit/yap.git/plain/yap-6.2.2-Friend-function-template-defined-in-a-class-cannot-b.patch
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ patch -p1 -i ../friend-function.patch
+
+ ./configure \
+ --prefix=/usr \
+ --enable-threads \
+ --enable-dynamic-loading \
+ --enable-max-performance \
+ --enable-max-memory
+ # --with-java="${JAVA_HOME}"
+ make
+
+ #make html
+ #make pdf
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ #make DESTDIR="${pkgdir}" install_docs
+}