summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Wolf2018-03-22 09:18:20 +0100
committerSebastian Wolf2018-03-22 09:18:20 +0100
commitb58623c3a081d885551f0c3da0c82ae9981159cb (patch)
tree06bf949ffabfddd485d51b1efd5597ae56368384 /PKGBUILD
parent1af41aad34d282638d7bcb450e6e2ee8724e46e1 (diff)
downloadaur-b58623c3a081d885551f0c3da0c82ae9981159cb.tar.gz
Moved to GitHub
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f94a7e05aeb6..21073f74621c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Contributor: Sebastian Wolf <fatmike303 at googlemail dot com>
pkgname=yape
+_pkgname=yapesdl
pkgver=0.70.2
-pkgrel=1
-_projectname=yapesdl
-_git_hash=7b2c2a123daf
-pkgdesc='A decent multiplatform Commodore plus/4 and 64 emulator written in C++ using the SDL 2.0 media API'
-arch=('i686' 'x86_64')
-url='http://yapesdl.codeplex.com'
-license=('GPL')
-depends=('sdl2')
-source=(${_projectname}::git+https://git01.codeplex.com/${_projectname})
-md5sums=(SKIP)
+pkgrel=2
+pkgdesc="Multiplatform Commodore 64 and 264 family emulator written in C++ using SDL2"
+arch=(i686 x86_64)
+url=https://github.com/calmopyrin/yapesdl
+license=(GPL)
+depends=(sdl2)
+source=(https://github.com/calmopyrin/${_pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=(daecce901b6465c55889094f67f0b4147a95008305f159a32302689fdcad69a6)
build() {
- cd ${srcdir}/${_projectname}
- git reset --hard ${_git_hash}
- make
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ make
}
package() {
- install -Dm755 ${srcdir}/${_projectname}/${_projectname} ${pkgdir}/usr/bin/${pkgname}
+ install -Dm755 ${srcdir}/${_pkgname}-${pkgver}/${_pkgname} ${pkgdir}/usr/bin/${pkgname}
}