summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarcan1s2015-11-23 00:40:19 +0300
committerarcan1s2015-11-23 00:40:19 +0300
commit3b869106bde83d7c151d6639dc2dcc396d4646fb (patch)
treef37376f2a1446552202dd8b9c3d8b3385cffd43b /PKGBUILD
parent50497c540fa5caae62721effa18fada66935ff73 (diff)
downloadaur-3b869106bde83d7c151d6639dc2dcc396d4646fb.tar.gz
fix build with the newest taglib
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 006c65950cff..7015577477bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=yarock-qt5
pkgver=1.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="Qt Modern Music Player with collection browse based on cover art"
arch=('i686' 'x86_64')
url="https://launchpad.net/yarock"
license=('GPL3')
makedepends=('cmake' 'mpv')
-depends=('htmlcxx' 'qt5-x11extras' 'phonon-qt5' 'taglib')
+depends=('htmlcxx' 'qt5-x11extras' 'phonon-qt5' 'taglib>=1.10')
optdepends=('mpv: alternative (working) engine')
source=("https://launchpad.net/yarock/1.x/${pkgver}/+download/Yarock_${pkgver}_source.tar.gz"
"phonon.patch")
@@ -28,7 +28,8 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_QT5=1 \
- -DENABLE_MPV=ON
+ -DENABLE_MPV=ON \
+ -DTAGLIB_MIN_VERSION=1.10
make
}