summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfossdd2021-06-12 11:34:10 +0000
committerfossdd2021-06-12 11:34:10 +0000
commit5a2e1a7bf39ed211ca9f441157c9a34bfae2fc44 (patch)
tree6b84b950ee12e608b00e3c38658996d82af7d3da /PKGBUILD
parent81018d8ad5cd8fe50064da2b0932735521cff54f (diff)
downloadaur-5a2e1a7bf39ed211ca9f441157c9a34bfae2fc44.tar.gz
remove gofeed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b27f51d3d111..9db40b4d0c91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: fossdd <fossdd@tutanota.com>
pkgname=yarr-git
_pkgname=yarr
-pkgver=v1.3.r0.g0916f11
+pkgver=v2.0.r29.g0c5385c
pkgrel=1
pkgdesc="yet another rss reader."
arch=('i686' 'x86_64')
url='https://github.com/nkanaev/yarr'
license=('MIT')
-source=('git+git://github.com/nkanaev/yarr' 'git+git://github.com/nkanaev/gofeed')
+source=('git+git://github.com/nkanaev/yarr')
depends=()
makedepends=('go' 'make' 'git')
-sha1sums=('SKIP' 'SKIP')
+sha1sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -20,17 +20,12 @@ pkgver() {
)
}
-prepare() {
- cd "$srcdir"
- mv "gofeed" "$_pkgname"
-}
-
build(){
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
make build_linux
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
install -Dm755 '_output/linux/yarr' "$pkgdir/usr/bin/yarr"
}