summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicola Murino2018-07-25 14:12:25 +0200
committerNicola Murino2018-07-25 14:12:25 +0200
commitea0edeb78192e786e2ea3bf9cbe68d877687c4cc (patch)
treec61c3d224ab371b542861d74b8860314551821a3 /PKGBUILD
parent42e583e9b01050cca7b029e9d15ec6e77ba28550 (diff)
downloadaur-ea0edeb78192e786e2ea3bf9cbe68d877687c4cc.tar.gz
Release 18.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b082e003974..2a5e8e51e104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgbase=yaru
pkgname=('yaru-sound-theme' 'yaru-gtk-theme' 'yaru-gnome-shell-theme' 'yaru-icon-theme')
-pkgver=b589893d
-pkgrel=4
-_gitname=yaru
+pkgver=18.10
+pkgrel=1
pkgdesc="Yaru default ubuntu theme"
arch=(any)
url="https://github.com/ubuntu/yaru"
@@ -11,18 +10,19 @@ license=('GPL3')
makedepends=('meson' 'sassc' 'git')
options=('!strip' '!buildflags' 'staticlibs')
-conflicts=('yaru')
+conflicts=('yaru-git')
+_commit=684f3d3f9cf9f7fd793f80e2fcf38dde7f970a43 # 18.10
-source=("$_gitname::git://github.com/ubuntu/$_gitname")
+source=("git+https://github.com/ubuntu/${pkgbase}#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${_gitname}"
- printf "%s" "$(git describe --always --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd ${pkgbase}
+ git describe --tags | sed 's/-/+/g'
}
build() {
- arch-meson ${_gitname} build
+ arch-meson ${pkgbase} build
ninja -C build
}