summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChilledheart2023-08-10 16:01:02 +0800
committerChilledheart2023-08-10 16:14:53 +0800
commit69fe01dfe54f9b370db4b14fb42b37520ba47ae3 (patch)
tree4c6971b737103c519c2a77693c800fed571c5c07 /PKGBUILD
parent2b6304710af5a1a64e8f5bdcfffe13c5fc1a9fd3 (diff)
downloadaur-69fe01dfe54f9b370db4b14fb42b37520ba47ae3.tar.gz
fix broken build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c67ccdaf4267..3427a283c59e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,16 @@
pkgname=yass-new
pkgver=1.3.13
-pkgrel=1
+pkgrel=2
+_pkgver=1.3.13
+_pkgrel=1
pkgdesc="lightweight http/socks proxy"
arch=(i686 x86_64)
url="https://github.com/Chilledheart/yass"
license=('GPL 2.0')
depends=(gcc-libs glibc gtk4)
optdepends=(gtk-update-icon-cache)
-makedepends=(git ninja perl pkg-config cmake gtk4 gettext curl go)
+makedepends=(git ninja perl pkg-config cmake gtk4 gettext curl)
checkdepends=("curl")
provides=(yass)
conflicts=(yass-git)
@@ -20,7 +22,7 @@ source=(
sha256sums=('197111e200b19b6e0fb00384b587cb6218e5702cb458ae6bd6f2930e3db7c5d8')
prepare() {
- SRC_DIR="${srcdir}/yass-${_pkgver}/src"
+ SRC_DIR="${srcdir}/yass-${_pkgver}"
pushd $SRC_DIR
./scripts/download-clang-prebuilt-binaries.py
cd tools
@@ -30,27 +32,34 @@ prepare() {
}
build(){
- SRC_DIR="${srcdir}/yass-${_pkgver}/src"
+ SRC_DIR="${srcdir}/yass-${_pkgver}"
pushd $SRC_DIR
export CC=$PWD/third_party/llvm-build/Release+Asserts/bin/clang
export CXX=$PWD/third_party/llvm-build/Release+Asserts/bin/clang++
- ./tools/build --variant gui --system linux -build-test
+ #./tools/build --variant gui --system linux -build-test
+ mkdir build-linux-amd64
+ cd build-linux-amd64
+ cmake .. -DGUI=ON -DCMAKE_BUILD_TYPE=Release -G Ninja -DBUILD_TESTS=on -DUSE_LIBCXX=on -DENABLE_LTO=on
+ ninja yass yass_test
+ ../third_party/llvm-build/Release+Asserts/bin/llvm-objcopy --strip-debug yass
+ cd ..
+
popd
}
check() {
- SRC_DIR="${srcdir}/yass-${_pkgver}/src"
+ SRC_DIR="${srcdir}/yass-${_pkgver}"
pushd $SRC_DIR
./build-linux-amd64/yass_test
popd
}
package(){
- SRC_DIR="${srcdir}/yass-${_pkgver}/src"
+ SRC_DIR="${srcdir}/yass-${_pkgver}"
pushd $SRC_DIR
install -Dm755 build-linux-amd64/yass ${pkgdir}/usr/bin/yass
- install -Dm644 build-linux-amd64/LICENSE ${pkgdir}/usr/share/licenses/yass/LICENSE
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/yass/LICENSE
install -Dm644 src/gtk/yass.desktop ${pkgdir}/usr/share/applications/yass.desktop
install -Dm644 src/gtk/icons/16x16/apps/yass.png ${pkgdir}/usr/share/icons/hicolor/16x16/apps/yass.png