summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChilledheart2023-10-08 11:24:12 +0800
committerChilledheart2023-10-08 11:24:12 +0800
commitba90ca6d6da75d0f1c846cff2bf76c3352a68c9e (patch)
treec0526692297a1fa5b4d7339e4ca20c508ca1ef2a /PKGBUILD
parentbdc98023b2a4b33d6821cbd08f20fa25115e788e (diff)
downloadaur-ba90ca6d6da75d0f1c846cff2bf76c3352a68c9e.tar.gz
update for 1.4.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbae44942040..c7885e4b4724 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: Chilledheart <hukeyue@hotmail.com>
pkgname=yass-proxy
-pkgver=1.4.4
+pkgver=1.4.5
pkgrel=1
-_pkgver=1.4.4
-_pkgrel=2
+_pkgver=1.4.5
+_pkgrel=1
pkgdesc="lightweight http/socks proxy"
arch=(x86_64)
url="https://github.com/Chilledheart/yass"
@@ -17,7 +17,7 @@ checkdepends=(curl)
provides=(yass-proxy)
conflicts=(yass-proxy-git)
source=("https://github.com/Chilledheart/yass/releases/download/${_pkgver}/yass-${_pkgver}.tar.gz")
-sha256sums=('939967ea99fce87320aa187229615eb8c377400ea3e6be916026ef2a5e54371e')
+sha256sums=('abe4a76fbd2800af110910b710d0b32d26c0124a15d0080a270397284efe0d54')
prepare() {
SRC_DIR="${srcdir}/yass-${_pkgver}"
@@ -57,8 +57,9 @@ package(){
SRC_DIR="${srcdir}/yass-${_pkgver}"
pushd $SRC_DIR
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/yass/LICENSE
+ install -Dm644 ./build-linux-amd64/LICENSE ${pkgdir}/usr/share/licenses/yass/LICENSE
DESTDIR=${pkgdir} ninja -C build-linux-amd64 install
+ rm -rf ${pkgdir}/usr/share/doc
popd
}