summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkarel2019-12-03 14:32:51 +0200
committerkarel2019-12-03 14:32:51 +0200
commit93e846a79174c21a1b727812544cbe9fce3a39fd (patch)
tree20bb9dce7655ef810d9afe74d856893eaf575737 /PKGBUILD
parent8e1aa0771c6556fd87b4597bfa951f2d320c6949 (diff)
downloadaur-93e846a79174c21a1b727812544cbe9fce3a39fd.tar.gz
Remove frozendict
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb6c9be2de2d..0157a16032be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ycmd-git
_gitname=ycmd
-pkgver=r2493.f8f50d4e
+pkgver=r2509.d02aec3d
pkgrel=1
pkgdesc="A code-completion & code-comprehension server"
arch=('i686' 'x86_64')
@@ -14,14 +14,13 @@ provides=('ycmd')
conflicts=('ycmd')
source=("git+https://github.com/Valloric/ycmd.git"
"git+https://github.com/bottlepy/bottle.git"
- "git+https://github.com/slezica/python-frozendict.git"
"git+https://github.com/davidhalter/jedi.git"
"git+https://github.com/davidhalter/parso.git"
"git+https://github.com/PythonCharmers/python-future.git"
"git+https://github.com/requests/requests.git"
"git+https://github.com/Pylons/waitress.git"
"git+https://github.com/davidhalter/typeshed.git")
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_gitname"
@@ -31,14 +30,12 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
git submodule init third_party/bottle \
- third_party/frozendict \
third_party/jedi_deps/jedi \
third_party/jedi_deps/parso \
third_party/python-future \
third_party/requests_deps/requests \
third_party/waitress
git config submodule.third_party/bottle.url $srcdir/bottle
- git config submodule.third_party/frozendict.url $srcdir/python-frozendict
git config submodule.third_party/jedi_deps/jedi.url $srcdir/jedi_deps/jedi
git config submodule.third_party/jedi_deps/parso.url $srcdir/jedi_deps/parso
git config submodule.third_party/python-future.url $srcdir/python-future
@@ -63,7 +60,7 @@ package() {
mkdir -p "$pkgdir/$trgtdir/third_party"
cp -r "$srcdir/$_gitname/"{ycmd,ycm_core.so,CORE_VERSION,cpp} \
"$pkgdir/$trgtdir"
- cp -r "$srcdir/$_gitname/third_party/"{bottle,clang,frozendict,jedi_deps,python-future,requests_deps,waitress} \
+ cp -r "$srcdir/$_gitname/third_party/"{bottle,clang,jedi_deps,python-future,requests_deps,waitress} \
"$pkgdir/$trgtdir/third_party"
find "$pkgdir" -name .git -exec rm -fr {} +
rm -rf "$pkgdir/$trgtdir/ycmd/tests"