summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Engestrom2021-03-21 23:26:52 +0100
committerEric Engestrom2021-03-21 23:36:48 +0100
commit5b6a0ebf1cd2b3b9709b63f7efe9038ea6079a08 (patch)
tree69330b43c504b43725fd3ae75cd8166dd76aa47a /PKGBUILD
parentdc15aabc23434bb7cb54205e6cb6585072ca8ba9 (diff)
downloadaur-5b6a0ebf1cd2b3b9709b63f7efe9038ea6079a08.tar.gz
pull unreleased upstream fix for the build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index caaa20a022e3..5dfeaf94a2d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,31 +9,27 @@ depends=('libevdevplus' 'libuinputplus' 'boost-libs')
makedepends=('cmake' 'ninja' 'boost' 'scdoc')
url="https://github.com/ReimuNotMoe/ydotool"
license=('AGPL3')
-source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('2311b003d2ff383f3348f17101f0df74f56616d530d66d0a014a52ba85a5dcf1')
+source=("$url/archive/v$pkgver.tar.gz"
+ "$url/pull/96.patch")
+sha256sums=('2311b003d2ff383f3348f17101f0df74f56616d530d66d0a014a52ba85a5dcf1'
+ 'f462b5f62306a5431e5aa39d1a8ba670300f7304a15cc720af5ded65193eaeda')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -sp1 -i ../96.patch
+}
build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_MANDIR=/usr/share/man \
-DCMAKE_BUILD_TYPE=Release \
-DCXXOPTS_ENABLE_INSTALL=OFF \
-G Ninja \
-S "$pkgname-$pkgver" -B build
ninja -C build
-
- scdoc < "$pkgname-$pkgver"/manpage/ydotool.1.scd > "build/ydotool.1"
- scdoc < "$pkgname-$pkgver"/manpage/ydotoold.8.scd > "build/ydotoold.8"
}
package() {
- #TODO: install is broken upstream
- # DESTDIR="$pkgdir" ninja -C build install
-
- install -Dm755 build/ydotool "$pkgdir/usr/bin/ydotool"
- install -Dm755 build/ydotoold "$pkgdir/usr/bin/ydotoold"
-
- install -Dm644 build/ydotool.1 "$pkgdir/usr/share/man/man1/ydotool.1"
- install -Dm644 build/ydotoold.8 "$pkgdir/usr/share/man/man8/ydotoold.8"
-
- install -Dm644 "$pkgname-$pkgver"/Daemon/ydotool.service "$pkgdir/usr/lib/systemd/user/ydotool.service"
+ DESTDIR="$pkgdir" ninja -C build install
}