summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRasmus Moorats2021-10-19 13:27:16 +0300
committerRasmus Moorats2021-10-19 14:40:56 +0300
commitd61b1207af35ad7f56c11fdb79cff7773d1d064e (patch)
tree7ab8fa7913576ade58ed033edc0b13174568e870 /PKGBUILD
downloadaur-ykcs11-p11-kit-module.tar.gz
add PKGBUILD, .SRCINFO, and module file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41df8a6453de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Rasmus Moorats <xx@nns.ee>
+pkgname=ykcs11-p11-kit-module
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='YubiKey PKCS#11 module configuration for p11-kit'
+url='https://developers.yubico.com/yubico-piv-tool/YKCS11/'
+arch=('any')
+license=('Unlicense')
+source=('ykcs11.module')
+depends=('yubico-piv-tool' 'libp11-kit')
+provides=('ykcs11-p11-kit-module')
+sha256sums=('576ad503a06f0d99e4dee211cc565b86e223bf1bc351df7b0ece503674a24ad6')
+
+package() {
+ cd "$srcdir/"
+
+ install -Dm644 ykcs11.module "${pkgdir}/usr/share/p11-kit/modules/ykcs11.module"
+}