summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsumt2017-07-20 12:20:50 +0300
committersumt2017-07-20 12:21:37 +0300
commit34db17a596db047a44df30f26034f0c9cfcaffd4 (patch)
tree39f299c21d21c8f92d0f9128c0fc49c5f1269238 /PKGBUILD
parent8cdc6a4ff6dc401ccf6842353b5dcdc442029805 (diff)
downloadaur-34db17a596db047a44df30f26034f0c9cfcaffd4.tar.gz
Updated to use setuptools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 874502f37768..4f9e81c2babb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jesse Jaara <gmail.com: jesse.jaara>
pkgname=yle-dl-git
-pkgver=2.19.r0.g7696802
+pkgver=2.20.r2.g74df6a1
pkgrel=1
pkgdesc="Download video and audio from YLE Areena."
arch=("any")
@@ -11,7 +11,7 @@ license=("GPL3")
depends=('ffmpeg' 'php' 'php-mcrypt' 'python2-crypto')
optdepends=('python2-youtube-dl: an alternative downloader backend'
'rtmpdump: for downloading Areena audio streams')
-makedepends=("git")
+makedepends=('git' 'python2-setuptools')
provides=(${pkgname%-git}=$pkgver)
conflicts=(${pkgname%-git})
source=("$pkgname::git+https://github.com/aajanki/yle-dl.git")
@@ -24,16 +24,13 @@ pkgver() {
prepare() {
cd "$pkgname"
- # Replace the hardcoded path for AdobeHDS.php
- sed -i 's|/usr/local/share/yle-dl/AdobeHDS.php|/usr/share/yle-dl/AdobeHDS.php|g' yle-dl
# Enable required PHP extensions by directly
# appending them to the hds_binary arguments list.
# OR enable them globaly in php.ini
- sed -i "s|^hds_binary = \['php'|hds_binary = \['php', '-dextension=bcmath.so', '-dextension=curl.so', '-dextension=mcrypt.so'|" yle-dl
+ sed -i "s|^hds_binary = \['php'|hds_binary = \['php', '-dextension=bcmath.so', '-dextension=curl.so', '-dextension=mcrypt.so'|" yledl/yledl.py
}
package() {
cd "$pkgname"
- make prefix=/usr DESTDIR="${pkgdir}" install
+ python2 setup.py install --root="$pkgdir/" --optimize=1
}
-