summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcippaciong2016-02-20 10:32:19 +0100
committercippaciong2016-02-20 10:32:19 +0100
commit5d5570d1949320b5b5d31cb3aa3e2b8aea3a5419 (patch)
tree0d0715661aa982b56b817ef9ae8b85ba2cabd0c3 /PKGBUILD
parent0e4dad8af3129385d78d1065432e3f35d57679ef (diff)
downloadaur-5d5570d1949320b5b5d31cb3aa3e2b8aea3a5419.tar.gz
Fix error when build directory already exists and add .install file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ff5d1ce18be..efe34b12612d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
pkgname=ympd
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="A standalone MPD Web GUI"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://www.ympd.org"
license=('GPL2')
depends=('libmpdclient' 'openssl')
makedepends=('cmake')
+provides=("$pkgname")
+conflicts=("$pkgname-git")
+install="${pkgname}.install"
+backup=('etc/default/ympd')
source=("https://github.com/notandy/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('d9f68920cd93d1cfa971e1d7b9162a2b1724909bc9753c1338cecb3688d234d5')
build() {
cd $srcdir/$pkgname-$pkgver
- mkdir build && cd build;
+ mkdir -p build && cd build;
cmake .. -DCMAKE_INSTALL_PREFIX:PATH=/usr
make
}