summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Bøe2015-10-14 18:05:40 +0000
committerSebastian Bøe2015-10-14 18:08:15 +0000
commit156490480ef3380040df98bd4f3b2ad6a123fe96 (patch)
treeb939b7e04d0dc254c5610fdc17bdf818d89fbc81 /PKGBUILD
parenta71fc1c12961ddd84e2d781cb71038f9e038e996 (diff)
downloadaur-156490480ef3380040df98bd4f3b2ad6a123fe96.tar.gz
Added license.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f170cf111e0..a86e7ba9e8cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,16 @@ pkgver=r2435.e51dcc8
pkgdesc='A framework for RTL synthesis'
arch=('x86_64' 'i686')
url='http://www.clifford.at/yosys/'
-license=('ISC')
+license=('custom:ISC')
provides=("yosys")
conflicts=("yosys")
depends=('tcl' 'libffi' 'clang' 'python')
optdepends=('graphviz: Schematics display support')
makedepends=('git' 'mercurial')
-source=('git+https://github.com/cliffordwolf/yosys.git')
-sha512sums=('SKIP')
+source=('git+https://github.com/cliffordwolf/yosys.git'
+ 'LICENSE')
+sha512sums=('SKIP'
+ 'a3202289ff7828c55d3ec3e22d23ed78a34fcae165a7c666d71d3cedd9abe06f638a09750d8c2d43dfca5781f1b32a616f439c3713a12265c02473f88c0f426d')
build(){
cd ${srcdir}/yosys
@@ -28,4 +30,8 @@ pkgver() {
package() {
cd ${srcdir}/yosys
make DESTDIR="$pkgdir/usr/" install
+
+ install -D -m 644 \
+ "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}