summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Lloyd2019-02-04 00:43:35 -0800
committerPatrick Lloyd2019-02-04 00:43:35 -0800
commit877d5051e00997c669978663d94195a0f0d8c5c9 (patch)
tree7333677a59741834484c0a895f93449db74dd145 /PKGBUILD
parentd8cec5528c82301d67385bacb11e05dfb27007b1 (diff)
downloadaur-877d5051e00997c669978663d94195a0f0d8c5c9.tar.gz
added contributors, added abc as source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29dd9000eac3..14cce2482abb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
-# Maintainer: Sebastian Bøe <sebastianbooe at gmail dot com>
+# Maintainer: Patrick Lloyd <$(base64 --decode <<<'cGF0cmlja0BsbG95ZC5zaAo=')>
+# Contributor: Sebastian Bøe <$(base64 --decode <<<'c2ViYXN0aWFuYm9vZUBnbWFpbC5jb20K')>
+# Contributor: Darren Wu <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
pkgname=yosys-git
pkgrel=1
-pkgver=r2755.5700148
+pkgver=r4323.266511b2
pkgdesc='A framework for RTL synthesis'
arch=('x86_64' 'i686')
url='http://www.clifford.at/yosys/'
license=('custom:ISC')
provides=("yosys")
conflicts=("yosys")
-depends=('tcl' 'libffi' 'python' 'xdot')
-optdepends=('graphviz: Schematics display support')
+depends=('tcl' 'libffi' 'python')
+optdepends=('graphviz: Schematics display support' 'xdot: Design netlist display support')
makedepends=('git' 'mercurial')
source=('git+https://github.com/cliffordwolf/yosys.git'
+ 'git+https://github.com/berkeley-abc/abc.git'
'LICENSE')
sha512sums=('SKIP'
+ 'SKIP'
'a3202289ff7828c55d3ec3e22d23ed78a34fcae165a7c666d71d3cedd9abe06f638a09750d8c2d43dfca5781f1b32a616f439c3713a12265c02473f88c0f426d')
build(){
cd ${srcdir}/yosys
+ mv ../abc ./
make config-gcc
make
}