summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfkxxyz2022-02-03 18:20:20 +0800
committerfkxxyz2022-02-03 18:20:20 +0800
commit9a4bea215b02fbba72c781e687405972aec3df1a (patch)
treea8be9a919eb502a07a9054a254eb8806f0c201b2 /PKGBUILD
parent0e64a8fc2b764f2cfdada8cd40fae9129fde1f6e (diff)
downloadaur-9a4bea215b02fbba72c781e687405972aec3df1a.tar.gz
fix-windows-pos-type.patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92631b87458e..e2f50fbe372f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: yesuu zhang <yesuu79@qq.com>
-# Contributor: qaz <fkxxyz@163.com>
+# Contributor: fkxxyz <fkxxyz@163.com>
pkgname=youdao-dict
pkgver=6.0.0
-pkgrel=3
+pkgrel=4
pkgdesc='YouDao Dictionary'
arch=('i686' 'x86_64')
url='https://cidian.youdao.com/'
@@ -29,15 +29,24 @@ depends=(
'qt5-quickcontrols'
'qt5-multimedia'
)
-source_i686=('http://codown.youdao.com/cidian/linux/youdao-dict_6.0.0_i386.tar.gz')
-source_x86_64=('http://codown.youdao.com/cidian/linux/youdao-dict-6.0.0-amd64.tar.gz')
+source=("file://fix-windows-pos-type.patch")
+source_i686=("http://codown.youdao.com/cidian/linux/youdao-dict_${pkgver}_i386.tar.gz")
+source_x86_64=("http://codown.youdao.com/cidian/linux/youdao-dict-${pkgver}-amd64.tar.gz")
+sha256sums=('886f217146232511107c16a8cfed82bc8da74e730f9d563e593543b1f33514a5')
sha256sums_i686=('d1ff404f1e465d6a196b566294ddfea1a1bfe4568226201b65d74236407152fc')
sha256sums_x86_64=('556e2dadd0a737967b78ffd9ad5430660d190e4489854a309c85f81fdf7f084f')
+build() {
+ cd "${srcdir}"
+ [ ${CARCH} == x86_64 ] && cd "youdao-dict-${pkgver}-amd64"
+
+ patch -p1 -i "${srcdir}/fix-windows-pos-type.patch"
+}
+
package() {
cd "${srcdir}"
[ ${CARCH} == x86_64 ] && cd "youdao-dict-${pkgver}-amd64"
-
+
sed -i -e "/PREFIX=/cROOT=${pkgdir}\nPREFIX=\$ROOT/usr" -e 's/\/etc/$ROOT\/etc/g' -e 's/ln -sf $PREFIX/ln -sf \/usr/g' install.sh
sh install.sh
}