summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsfx2016-01-07 19:10:20 +0100
committersfx2016-01-07 19:10:20 +0100
commit58810af7e1fc5132cd6a409ca08fbddfd8623ada (patch)
treee7a4a1f3d0ed28d52dafc045ab17e55f52c15c24 /PKGBUILD
parent24ec1f87295d0927091a463dda2b7375c95e7db2 (diff)
downloadaur-58810af7e1fc5132cd6a409ca08fbddfd8623ada.tar.gz
Allow updated build when previous source was already downloaded
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03cc95e8e1af..2477aab4f145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _name=youtube-dl
_branch=master
pkgname=$_name-git
-pkgver=2015.12.31.d5f6429
+pkgver=2016.01.07.2e02ecb
pkgrel=1
pkgdesc='A small command-line program to download videos from YouTube.com and a few more sites - git version'
@@ -22,15 +22,15 @@ optdepends=('ffmpeg: for video post-processing')
provides=("$_name")
conflicts=("$_name")
-source=("https://github.com/rg3/$_name/archive/$_branch.zip")
-sha512sums=(SKIP)
-
pkgver() {
DATE=$(date +%Y.%m.%d)
HASH=$(git ls-remote -h https://github.com/rg3/$_name $_branch | cut -c1-7)
echo $DATE.$HASH
}
+source=("$pkgname-$(pkgver).zip::https://github.com/rg3/$_name/archive/$_branch.zip")
+sha512sums=(SKIP)
+
prepare() {
cd $_name-$_branch
sed -i 's|etc/bash_completion.d|share/bash-completion/completions|' setup.py