summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122017-06-18 23:16:59 +0200
committerwillemw122017-06-23 07:56:15 +0200
commit2c2548fd2dbbf01bb39ccf156d14914d57967d11 (patch)
treef9d21bfabb981abf90f918fcd344d92295dad5aa /PKGBUILD
parent54620aff22d0354609b6e535567a32ab7e2715c2 (diff)
downloadaur-2c2548fd2dbbf01bb39ccf156d14914d57967d11.tar.gz
Add python2-twodict. Remove .install file. Remove "youtube-dl-gui.png" patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ffeb6d93798..29ebd364ec2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,18 @@
_pkgname=youtube-dl-gui
pkgname=$_pkgname-git
-pkgver=0.3.8.r64.gfa3de1d
+pkgver=0.3.8.r447.g182a587
pkgrel=1
pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython"
arch=('any')
url="https://github.com/MrS0m30n3/youtube-dl-gui"
license=('custom:UNLICENSE')
-depends=('gtk-update-icon-cache' 'python2' 'wxpython')
+depends=('gtk-update-icon-cache' 'python2-twodict' 'wxpython')
optdepends=('ffmpeg: convert video files to audio-only files'
- 'youtube-dl: alternative to the youtube-dl program file downloaded by youtube-dl-gui')
+ 'youtube-dl: alternative to the youtube-dl program downloaded by youtube-dl-gui')
makedepends=('git')
provides=($_pkgname)
conflicts=($_pkgname)
-install=$pkgname.install
source=($pkgname::git://github.com/MrS0m30n3/youtube-dl-gui.git
youtube-dl-gui.desktop)
md5sums=('SKIP'
@@ -32,13 +31,5 @@ package() {
cd $pkgname
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python2 setup.py install --root="$pkgdir" --optimize=1
-
- # Patch: add "youtube-dl-gui.png" icon filenames
- for dir in "$pkgdir"/usr/share/icons/hicolor/*/apps "$pkgdir/usr/share/pixmaps"; do
- cd "$dir"
- for icon in youtube-dl-gui_*.png; do
- ln -s $icon youtube-dl-gui.png
- done
- done
}