summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122021-07-03 11:14:51 +0200
committerwillemw122021-07-03 11:14:51 +0200
commit6022f537be5faec15142cd0341c3e50b2c0eb791 (patch)
tree05590e455c4fa574c673fd55a1d7690cbc9a25d0 /PKGBUILD
parent2b99f93f96012d05e1b5ae98d745a67caaab618d (diff)
downloadaur-6022f537be5faec15142cd0341c3e50b2c0eb791.tar.gz
Switch to oleksis' fork (Python 3)
Add translation (python-polib). Add undocumented dependencies (python-setuptools, xdg-utils). Add alternative build steps following upstream instructions (commented PKGBUILD and youtube-dl-gui startup script). Remove UNLICENSE file. Minor edits.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD89
1 files changed, 78 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1962b9387a11..a5a52041de34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,100 @@
# Contributor: B4SH-B00STER
pkgname=youtube-dl-gui-git
-pkgver=0.4.r81.gc5c18e5
-pkgrel=2
+pkgver=1.7.0.r12.g8dbf054
+pkgrel=1
pkgdesc="Cross platform front-end GUI of the popular youtube-dl written in wxPython"
arch=('any')
-url="https://github.com/MrS0m30n3/youtube-dl-gui"
+url="https://github.com/oleksis/youtube-dl-gui"
license=('custom:UNLICENSE')
-#depends=('python2-twodict' 'python2-wxpython3')
-depends=('python2-twodict-git' 'python2-wxpython3')
+# xdg-utils: xdg-open to open and play a file
+depends=('python-pypubsub' 'python-wxpython' 'xdg-utils')
optdepends=('ffmpeg: convert video files to audio-only files'
- 'youtube-dl: alternative to the youtube-dl program downloaded by youtube-dl-gui')
-makedepends=('git')
+ 'youtube-dl: alternative to the program downloaded by youtube-dl-gui')
+makedepends=('git' 'python-polib' 'python-setuptools')
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
source=($pkgname::git+$url.git
youtube-dl-gui.desktop)
sha256sums=('SKIP'
- '1f687872e8105394e8b41ab99f3923e87b1cb6c041602147d7847bc4b8f26e8d')
+ '0c98a9550084bf7b9fd1ac9c394c6499a129b9d439bab6a256b3a1f4695ce358')
pkgver() {
- git -C $pkgname describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+#build() {
+# cd $pkgname
+# python setup.py build build_trans
+#}
+
package() {
install -Dm644 youtube-dl-gui.desktop -t "$pkgdir/usr/share/applications"
+ install -Dm644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
cd $pkgname
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python setup.py build_trans install --root="$pkgdir" --optimize=1 # --skip-build
}
+
+
+# # Following the upstream build instructions
+# # Change the Exec= line in youtube-dl-gui.desktop to Exec=youtube-dl-gui
+#
+# pkgname=youtube-dl-gui-git
+# pkgver=0
+# pkgrel=1
+# pkgdesc="Cross platform front-end GUI of the popular youtube-dl written in wxPython"
+# arch=('any')
+# url="https://github.com/oleksis/youtube-dl-gui"
+# license=('custom:UNLICENSE')
+# # wxgtk3 is a wxpython dependency (see package python-wxpython)
+# # xdg-utils: xdg-open to open and play a file
+# depends=('wxgtk3' 'xdg-utils')
+# optdepends=('ffmpeg: convert video files to audio-only files'
+# 'youtube-dl: alternative to the program downloaded by youtube-dl-gui')
+# makedepends=('git')
+# provides=(${pkgname%-git})
+# conflicts=(${pkgname%-git})
+# source=($pkgname::git+$url.git
+# youtube-dl-gui.desktop
+# youtube-dl-gui)
+# sha256sums=('SKIP'
+# '0'
+# '0')
+#
+# pkgver() {
+# git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+# }
+#
+# #check() {
+# # cd $pkgname
+# #
+# # source venv/bin/activate
+# # make test
+# #}
+#
+# package() {
+# install -Dm755 youtube-dl-gui -t "$pkgdir/usr/bin"
+# install -Dm644 youtube-dl-gui.desktop -t "$pkgdir/usr/share/applications"
+# install -Dm644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+#
+# cd $pkgname
+#
+# export PIP_CONFIG_FILE=/dev/null
+# export TMPDIR="$srcdir/tmp"
+# export XDG_CACHE_HOME="$srcdir/cache"
+#
+# mkdir -p "$TMPDIR"
+#
+# make clean-requirements
+# make venv
+# source venv/bin/activate
+# make install
+#
+# rm -rf "$TMPDIR"
+#
+# install -dm755 "$pkgdir/usr/share/${pkgname%-git}"
+# cp -a venv "$pkgdir/usr/share/${pkgname%-git}"
+# }
+