summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-02-24 11:15:33 -0700
committerMark Wagie2023-02-24 11:15:33 -0700
commit7ab2b113fb1c2fafb28c7f4489e00f81ffe5d9fe (patch)
tree4cc2b8ef58760678e02ad07088691e5c72e76ea7 /PKGBUILD
parent8498860c0b7e7149f7e3e68be082ea482238d9fa (diff)
downloadaur-7ab2b113fb1c2fafb28c7f4489e00f81ffe5d9fe.tar.gz
set desktop file to use script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e0a57713f3e..e2839b5285d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
# Contributor: Harsh Barsaiyan <hbarsaiyan at gmail dot com>
pkgname=youtube-music-bin
pkgver=1.19.0
-pkgrel=2
+pkgrel=3
pkgdesc="YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)"
arch=('x86_64')
url="https://th-ch.github.io/youtube-music"
license=('MIT')
depends=('gtk3' 'libsecret' 'nss')
+makedepends=('setconf')
optdepends=('libnotify: desktop notifications'
'libappindicator-gtk3: tray icon')
provides=("${pkgname%-bin}")
@@ -23,6 +24,8 @@ sha256sums=('f8bebf16cd24463dd830bdf3dbd59cc6a4f44a5422a2b995f1ef8bb260325beb'
package(){
bsdtar xfv data.tar.xz -C "$pkgdir"
+ setconf "$pkgdir/usr/share/applications/${pkgname%-bin}.desktop" Exec "${pkgname%-bin} %U"
+
install -Dm755 "${pkgname%-bin}.sh" "$pkgdir/usr/bin/${pkgname%-bin}"
install -Dm644 license -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"