summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortrizen2020-07-15 17:51:55 +0300
committertrizen2020-07-15 17:51:55 +0300
commit6c55fee63bc0c45286858e2ce6a63d4527a09be2 (patch)
treeccfe5fef92720ca770e1e523dd65dd1211b8c361 /PKGBUILD
parent5c1e8d1ae98351ff48207dd154e472608af53724 (diff)
downloadaur-6c55fee63bc0c45286858e2ce6a63d4527a09be2.tar.gz
Use `git describe --long` in pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2f21c3d2d6d..0ff4e84f69f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=youtube-viewer
pkgname=youtube-viewer-git
-pkgver=3.7.7
+pkgver=3.7.7.r0.gc9f2913
pkgrel=1
pkgdesc="Command line utility for searching and streaming videos from YouTube."
arch=('any')
@@ -31,11 +31,10 @@ source=('git+https://github.com/trizen/youtube-viewer.git')
md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- git describe --always | sed -e 's|-|.|g'
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
PERL_AUTOINSTALL=--skipdeps \