summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcorey drew bruce2022-12-27 00:34:54 +1000
committercorey drew bruce2022-12-27 00:34:54 +1000
commitcbd0077454e74fa021812be3ce8c3ee34b96dbf8 (patch)
treeb3b1e994703a08a2504e194dd683ae64899b57c1 /PKGBUILD
parentad1dce6251d67a752092cfb2aa695f1454b87cd0 (diff)
downloadaur-cbd0077454e74fa021812be3ce8c3ee34b96dbf8.tar.gz
AUR PACKAGE HOTFIX ONLY - Added launch script for package manager use only, this will also be used to resolve the KDE launch issue as I make some changes to the PKGBUILD file on the AUR - Fixed issue with desktop shortcut
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11314838c7d9..5cfa65ab270a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
pkgname=youtubemusic
_pkgname=YoutubeMusic
pkgver=1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Youtube Music is a unofficial client to play your music."
-arch=('any')
+arch=('x86_64' 'aarch64')
url="https://gitlab.com/youtube-music/application"
license=('GPL')
conflicts=("youtubemusic-bin")
@@ -11,17 +11,10 @@ depends=('libelectron' 'nss' 'gtk3' 'libxss' 'git')
source=("https://gitlab.com/youtube-music/application/-/archive/$pkgver-$pkgrel/application-$pkgver-$pkgrel.tar.bz2")
sha256sums=('SKIP')
-
package() {
- for dir in application-$pkgver-$pkgrel ; do mv "${dir}" "$_pkgname" ;done
+ for dir in application-$pkgver-$pkgrel ; do mv "${dir}" "$_pkgname" ;done
cd "$srcdir/$_pkgname"
- cat <<EOT >> $_pkgname
- #!/bin/bash
- cd /opt/$_pkgname &&
- npm start
-EOT
-
- chmod +x $_pkgname
+ chmod +x $pkgname.sh
ln -sf "/opt/libelectron/node_modules" "$srcdir/$_pkgname"
install -dm755 "$pkgdir/opt/$_pkgname"
install -dm755 "$pkgdir/usr/share/pixmaps"
@@ -31,7 +24,7 @@ EOT
# Link to binary
install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/$_pkgname/$pkgname" "$pkgdir/usr/bin"
+ ln -s "/opt/$_pkgname/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
# Desktop Entry
install -Dm644 "$srcdir/$_pkgname/$_pkgname.desktop" \