diff options
author | Gr3q | 2022-03-06 09:18:43 +0000 |
---|---|---|
committer | Gr3q | 2022-03-06 09:18:43 +0000 |
commit | c57404f7449365e78d84ac86fa5362b14d359631 (patch) | |
tree | 24178032b35bf3fe8272a1beffcc913c8432bf0f /PKGBUILD | |
parent | dc5d382b1d914b929aee66a4ae0668ddb750c610 (diff) | |
download | aur-c57404f7449365e78d84ac86fa5362b14d359631.tar.gz |
stop using deprecated build and install methods
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 18 |
1 files changed, 15 insertions, 3 deletions
@@ -2,7 +2,7 @@ _pkgname=yt-dlg pkgname=$_pkgname-git -pkgver=1.2.0.r150.g4ac8184 +pkgver=1.2.0.r238.gf0fe39e pkgrel=1 pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)" arch=('any') @@ -15,7 +15,13 @@ depends=( ) optdepends=('ffmpeg: convert video files to audio-only files' 'youtube-dl: alternative to the youtube-dl program downloaded by yt-dlg') -makedepends=('git' 'python-polib' 'python-setuptools') +makedepends=( + 'git' + 'python-polib' + 'python-setuptools' + 'python-build' + 'python-installer' +) provides=($_pkgname) conflicts=($_pkgname youtube-dl-gui) source=($pkgname::git+https://github.com/yt-dlg/yt-dlg.git) @@ -25,11 +31,17 @@ pkgver() { git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' } +build() { + cd $pkgname + python setup.py build_trans + python -m build --wheel --no-isolation +} + package() { cd $pkgname install -Dm644 yt-dlg.desktop "$pkgdir/usr/share/applications/yt-dlg.desktop" install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" - python setup.py build_trans install --root="$pkgdir" --optimize=1 + python -m installer --destdir="$pkgdir" dist/*.whl } |