summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsolopasha2023-05-05 19:50:14 +0300
committersolopasha2023-05-05 19:50:14 +0300
commit4c614dcdf951a4edc8fbb6591beacec3fa03b944 (patch)
tree4f674cd4fad5fd28c90d6e89436adfae53c58b75 /PKGBUILD
parentc2164476d3c83816ed31e66bb34144aaa22ed657 (diff)
downloadaur-4c614dcdf951a4edc8fbb6591beacec3fa03b944.tar.gz
use default branch instead of master
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 710c3be00022..c2414c19dc24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: solopasha <daron439 at gmail dot com>
pkgname=ytarchive-git
-pkgver=r216.8d48052
+pkgver=r256.b40d0a1
pkgrel=1
pkgdesc="Garbage Youtube livestream downloader."
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/Kethsar/ytarchive"
license=("MIT")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
makedepends=(git go)
options=(!lto)
-source=("${pkgname}::git+${url}.git#branch=master")
+source=("${pkgname}::git+${url}.git")
sha512sums=('SKIP')
pkgver() {
@@ -20,14 +20,13 @@ pkgver() {
build() {
export GOPATH="$srcdir"/gopath
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export CGO_ENABLED=1
cd "$pkgname"
- go build -o "${pkgname%-git}"
+ go build -o "${pkgname%-git}" -ldflags \
+ "-linkmode=external -extldflags $LDFLAGS -X main.commit=${pkgver#*.}"
}
package(){
depends=(ffmpeg)