summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWolfgang Popp2020-10-21 20:52:05 +0200
committerWolfgang Popp2020-10-21 20:52:05 +0200
commitb3527d6b14539308d5d4a7beb64abbb8fe0516f2 (patch)
treed00980a5e10a26e3ca83c34f3943edd6eebb034c /PKGBUILD
parentddb003230493c9e6030d0ec8f3ed96863de46983 (diff)
downloadaur-b3527d6b14539308d5d4a7beb64abbb8fe0516f2.tar.gz
updated to v2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c925eee18de4..e95b8695c9d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer: Wolfgang Popp mail@wolfgang-popp.de
+# Maintainer: Wolfgang Popp <mail@wolfgang-popp.de>
pkgname=ytcc
-pkgver=1.8.5
+pkgver=2.0.0
pkgrel=1
-pkgdesc="The YouTube channel checker"
+pkgdesc="Command line tool to keep track of playlists"
arch=('any')
url="https://github.com/woefe/ytcc"
license=('GPL3')
-depends=('python' 'python-lxml' 'python-feedparser' 'python-sqlalchemy' 'mpv' 'youtube-dl')
-makedepends=()
+depends=('python-click' 'youtube-dl' 'python-wcwidth')
+optdepends=('mpv' 'fzf')
+makedepends=('git' 'python-setuptools')
source=("https://github.com/woefe/ytcc/archive/v${pkgver}.tar.gz")
-sha256sums=('4e301120a06988159f14f178380c5dd6cdf8e96c572cbb13888c6979d97e3c14')
+sha256sums=('a8cc651d1a304d092c356c87e2080f2313ad5ac982b9320e77e7844dfc1067c0')
package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
- install -Dm644 completions/zsh/_ytcc "${pkgdir}/usr/share/zsh/site-functions/_ytcc"
- install -Dm644 completions/fish/ytcc.fish "${pkgdir}/usr/share/fish/vendor_completions.d/ytcc.fish"
+ install -Dm755 scripts/ytccf.sh "${pkgdir}/usr/bin/ytccf"
+ install -Dm644 scripts/completions/zsh/_ytcc "${pkgdir}/usr/share/zsh/site-functions/_ytcc"
+ install -Dm644 scripts/completions/bash/ytcc.completion.sh "${pkgdir}/usr/share/bash-completion/completions/ytcc"
+ install -Dm644 scripts/completions/fish/ytcc.fish "${pkgdir}/usr/share/fish/vendor_completions.d/ytcc.fish"
+ install -Dm644 doc/ytcc.1 "${pkgdir}/usr/share/man/man1/ytcc.1"
}
# vim:set ts=2 sw=2 et: