summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkanehekili2024-04-01 23:20:58 +0200
committerkanehekili2024-04-01 23:20:58 +0200
commitb8b448d3cdff4cd7efb3ef635df27c9087bd213b (patch)
tree38952bbce6a7a08303f079aaea58545c8a6e232d /PKGBUILD
parent64c2cb3b10fc4bee804796a4cae6d442b1684a2c (diff)
downloadaur-b8b448d3cdff4cd7efb3ef635df27c9087bd213b.tar.gz
Reintroduce yt-dlp local
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b83a94ad0ef..39c80f3a9914 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Kanehekili (mat dot wegmann at gmail dot com)
pkgname=ytdownloader
-pkgver=1.4.5
+pkgver=1.4.6
pkgrel=1
pkgdesc="GKT3 frontend for yt-dlp (the active branch of youtube-dl) with focus on best audio and video. Uses ffmpeg for joining audio & video"
url="https://github.com/kanehekili/YoutubeDownloader"
license=('GPL2' 'MIT')
depends=('python' 'python-gobject' 'ffmpeg' 'yt-dlp')
arch=('any')
-source=(https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.5/ytdownloader1.4.5.tar)
-md5sums=(bd26a157273bbdc42d19f18899736afc)
+source=(https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.6/ytdownloader1.4.6.tar)
+md5sums=(0f213d16fc5d797ebc2a2d745cae7120)
package(){
cd ${srcdir}
@@ -17,11 +17,10 @@ package(){
mkdir -p "${pkgdir}/usr/bin"
rm $srcdir/$pkgname/install.sh
rm $srcdir/$pkgname/uninstall.sh
- rm $srcdir/$pkgname/yt-dlp
cp $srcdir/$pkgname/YtGui.desktop $pkgdir/usr/share/applications
cp -r $srcdir/$pkgname/* $pkgdir/opt/$pkgname
chmod +x ${pkgdir}/opt/${pkgname}/YtGui.py
- touch ${pkgdir}/opt/${pkgname}/ytextern
+ chmod a+rx ${pkgdir}/opt/${pkgname}/yt-dlp
ln -sf /opt/${pkgname}/YtGui.py ${pkgdir}/usr/bin/ytgui
}