summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortuftedocelot2019-09-23 19:37:17 -0500
committertuftedocelot2019-09-23 19:37:17 -0500
commitf9319d7f33d8b73b40460ad2aa4881ba3ce63e77 (patch)
treedda3a4fef656d081e889595fa34ac3a302dcf76e /PKGBUILD
parentd5ceb5ddea92858118f4babc9d1ee3e9c9da7918 (diff)
downloadaur-f9319d7f33d8b73b40460ad2aa4881ba3ce63e77.tar.gz
yubico-yubioath-desktop: vers bump, thanks egrupled
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65cee8ab93a6..9e9bef0a8b54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: tuftedocelot@fastmail.fm
_pkgname=yubioath-desktop
pkgname=yubico-${_pkgname}
-pkgver=4.3.6
+pkgver=5.0.0
pkgrel=1
pkgdesc="Crossplatform graphical user interface to generate one-time passwords."
arch=('x86_64')
url="https://developers.yubico.com/yubioath-desktop/"
license=('BSD')
-depends=('pcsclite' 'ccid' 'python-pyotherside' 'yubikey-manager>=0.7.0' 'qt5-quickcontrols')
+depends=('pcsclite' 'ccid' 'python-pyotherside' 'yubikey-manager>=3.1.0' 'qt5-quickcontrols2' 'qt5-declarative')
makedepends=('swig' 'qt5-svg' 'libffi' 'openssl' 'qt5-base' 'git')
validpgpkeys=('8D0B4EBA9345254BCEC0E843514F078FF4AB24C3' # Dag Heyman <dag@yubico.com>
- '5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23' # Emil Lundberg <emil@yubico.com>
'57A9DEED4C6D962A923BB691816F3ED99921835E' # Emil Lundberg <emil@yubico.com>
)
source=("git+https://github.com/Yubico/${_pkgname}.git#tag=${_pkgname}-${pkgver}?signed")
@@ -30,4 +29,6 @@ package() {
make INSTALL_ROOT="${pkgdir}/" install
install -D -m0644 resources/yubioath-desktop.desktop "${pkgdir}/usr/share/applications/yubioath-desktop.desktop"
install -D -m0644 resources/icons/yubioath.png "${pkgdir}/usr/share/pixmaps/yubioath.png"
+ install -D -m0644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
+