summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Mueller2019-01-20 22:47:38 +0100
committerAnton Mueller2019-01-20 22:47:38 +0100
commit9bd5bae3d47880a398672e661997babb18c5f355 (patch)
treeb7c566ae84bd3ec1dee214fd7d97a883c65d3f62 /PKGBUILD
downloadaur-9bd5bae3d47880a398672e661997babb18c5f355.tar.gz
added PKGBUILD .SRCINFO to git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6544b045cb5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer therojam <archlinux@therojam.xyz>
+
+pkgname=yubikey-full-disk-encryption-git
+pkgver=r82.a2843e1
+pkgrel=1
+pkgdesc='Use YubiKey to unlock a LUKS partition'
+arch=('any')
+url='https://github.com/agherzan/yubikey-full-disk-encryption'
+license=('GPL')
+depends=('yubikey-personalization' 'cryptsetup' 'udisks2' 'expect')
+makedepends=('git')
+backup=('etc/ykfde.conf')
+source=('git+https://github.com/agherzan/yubikey-full-disk-encryption.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ }
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" instal
+ }