summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgithub-actions[bot]2022-10-03 10:21:22 +0000
committergithub-actions[bot]2022-10-03 10:21:22 +0000
commit120b4e19c00862d4817a014fce13c7c059cf9087 (patch)
treef91ea7ba0c3ace137475973c9d4e0b841c9a7a7f /PKGBUILD
downloadaur-120b4e19c00862d4817a014fce13c7c059cf9087.tar.gz
Update AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf7c836a5878
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgver=0.2.0
+pkgname=yues
+pkgrel=1
+pkgdesc='Yue library provider for any language/framework'
+arch=(any)
+depends=(
+ luajit
+ yue-lua51-bin
+ lua51-filesystem
+ lua51-socket
+)
+makedepends=(
+)
+url='https://libyue.com/'
+license=('Custom')
+source=("git+https://github.com/KaMeHb-UA/yues.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/opt"
+ cp "$srcdir/yues/bin/yues" "$pkgdir/usr/bin/yues"
+ cp -r "$srcdir/yues/src" "$pkgdir/opt/yues"
+}