summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoratemu2019-07-21 20:17:08 +0200
committeratemu2019-07-21 20:17:08 +0200
commit57d65fb9429fc8d23581dcdb2c042b697486e9ba (patch)
treebbd7acee932a917496649f8ed79c132f8696e554 /PKGBUILD
downloadaur-57d65fb9429fc8d23581dcdb2c042b697486e9ba.tar.gz
Added VCS-ified PKGBUILD based on the original yup AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c065dd5b7a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=yup-git
+_pkgname=yup
+pkgver=v0.1.7.beta.r2.gb3d3888
+pkgrel=1
+pkgdesc="Arch Linux AUR Helper with ncurses functionality and better searching and sorting"
+arch=('any')
+url="https://github.com/ericm/yup"
+license=('GPL3')
+source=("${_pkgname}::git+https://github.com/ericm/yup.git")
+sha256sums=('SKIP')
+
+depends=('pacman>=5.1' 'git' 'ncurses' 'sudo')
+makedepends=('go>=1.12' 'make')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ make
+}
+
+package() {
+ install -dm755 ${pkgdir}/usr/local/bin/${BINAME}
+ cd "${_pkgname}"
+ cp ${_pkgname} ${pkgdir}/usr/local/bin/${BINAME}
+
+}