summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGitHub Action2021-11-05 02:08:02 +0000
committerGitHub Action2021-11-05 02:08:02 +0000
commit19dea34e744de785aa5085b5072e4bcd9e2f9948 (patch)
tree3b89d2fe87ec24796836a0c09da3296c3e7e348f /PKGBUILD
downloadaur-19dea34e744de785aa5085b5072e4bcd9e2f9948.tar.gz
Update from GitHub Actions: yutto: init at 2.0.0b5
https://github.com/ouuan/AUR-packages/actions/runs/1424039878
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ffa1c4bf361
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yufan You <ouuansteve at gmail>
+
+pkgname=yutto
+pkgver=2.0.0b5
+pkgrel=1
+pkgdesc='一个可爱且任性的 B 站视频下载器'
+arch=('any')
+url='https://github.com/SigureMo/yutto'
+license=('GPL3')
+depends=(
+ 'python-aiohttp'
+ 'python-aiofiles'
+ 'python-biliass'
+ 'python-dicttoxml'
+)
+makedepends=('python-setuptools' 'python-wheel')
+optdepends=('python-uvloop: fast asyncio event loop')
+source=("https://pypi.io/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('10a8363119bcfdca5c704b9e3781a376b34cc1adb93d62562ab58330a38da56d')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ rm -rf "$pkgdir/usr/lib/"*"/site-packages/tests" || true
+}