summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrendan Szymanski2019-08-28 19:13:46 -0400
committerBrendan Szymanski2019-08-28 19:13:46 -0400
commitf91b2793b61663804daee4c108f64323cc3bcd92 (patch)
tree0f4ddd009442fbd2aec8d82f46fa8dc1fcac8e2d /PKGBUILD
parent9a77bb430eeca319e7187334f36d5cc22d173594 (diff)
downloadaur-f91b2793b61663804daee4c108f64323cc3bcd92.tar.gz
Update package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[-rwxr-xr-x]PKGBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 365d87648ca1..b9aa28c2bc90 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,15 @@
-# Maintainer: bscubed <bscubed@pm.me>
+# Maintainer: Brendan Szymanski <brendan.szymanski1@gmail.com>
-_pkgname='yuzu-canary'
-pkgname="$_pkgname-git"
-pkgver=r12153.f83d9adca
+_pkgname=yuzu
+pkgname=$_pkgname-canary-git
+pkgver=r12355.7510df6ab
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/yuzu-emu/yuzu-canary"
license=('GPL2')
-provides=('yuzu' 'yuzu-cmd')
-conflicts=('yuzu-git')
-depends=('shared-mime-info'
- 'desktop-file-utils'
- 'sdl2'
- 'qt5-base'
- 'qt5-multimedia'
- 'qt5-tools'
- 'qt5-webengine'
- 'libxkbcommon-x11'
- 'libzip'
- 'zlib')
-makedepends=('git'
- 'cmake'
- 'python2')
+depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia' 'qt5-tools' 'libxkbcommon-x11')
+makedepends=('git' 'cmake' 'python')
optdepends=('qt5-wayland: for Wayland support')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary")
md5sums=('SKIP')
@@ -54,9 +41,8 @@ build() {
mkdir -p build && cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DYUZU_USE_BUNDLED_UNICORN=ON \
- -DYUZU_USE_QT_WEB_ENGINE=ON \
-DCMAKE_BUILD_TYPE=Release \
+ -DYUZU_USE_BUNDLED_UNICORN=ON \
-DYUZU_ENABLE_COMPATIBILITY_REPORTING=ON \
-DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
-DUSE_DISCORD_PRESENCE=ON
@@ -70,6 +56,5 @@ check() {
package() {
cd "$srcdir/$_pkgname/build"
-
make DESTDIR="$pkgdir/" install
}