summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrendan Szymanski2022-05-03 00:22:18 -0400
committerBrendan Szymanski2022-05-03 00:22:18 -0400
commite845981ded797a78623f55dec2d4add4ec01a4f4 (patch)
treefd5dd09af04c691b4dbe484e999d86997104f415 /PKGBUILD
parent1012b5298638fe1413a94fd2eeab8e876709b372 (diff)
downloadaur-e845981ded797a78623f55dec2d4add4ec01a4f4.tar.gz
Removed soundtouch from list of submodule dependencies
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af29040f1c7f..5819903c3cd4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-git
-pkgver=r19935.720970c4c
+pkgver=r21376.8037f2eae
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch'
arch=('i686' 'x86_64')
@@ -40,7 +40,6 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/benhoyt/inih.git'
'git+https://github.com/kinetiknz/cubeb.git'
'git+https://github.com/MerryMage/dynarmic.git'
- 'git+https://github.com/citra-emu/ext-soundtouch.git'
'libressl::git+https://github.com/citra-emu/ext-libressl-portable.git'
'git+https://github.com/libusb/libusb.git'
'git+https://github.com/discord/discord-rpc.git'
@@ -72,7 +71,6 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -83,10 +81,10 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
+ for submodule in externals/{inih/inih,cubeb,dynarmic,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update
+ git submodule update --init
done
cd "$srcdir/$_pkgname"/externals/cubeb
@@ -94,7 +92,7 @@ prepare() {
for submodule in cmake/sanitizers-cmake; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update
+ git submodule update --init
done
cd "$srcdir/$_pkgname"/externals/sirit
@@ -102,7 +100,7 @@ prepare() {
for submodule in externals/SPIRV-Headers; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update
+ git submodule update --init
done
}