summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrendan Szymanski2020-04-23 22:35:37 -0400
committerBrendan Szymanski2020-04-23 22:35:37 -0400
commitecef42d356c31d1f39c98f3533e81940196c9729 (patch)
tree5ddac0050b4bc2c07833412bf37cbcdfc887e0a6 /PKGBUILD
parent3b988dee45cac7b1ae076d6665c51e64d9f06e64 (diff)
downloadaur-ecef42d356c31d1f39c98f3533e81940196c9729.tar.gz
Include temporary workaround until issue 3754 is resolved https://github.com/yuzu-emu/yuzu/issues/3754
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0dea2b92412..4633b5a3f255 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname='yuzu'
pkgname="$_pkgname-git"
-pkgver=r13623.aa3f9b960
+pkgver=r14488.f24c67877
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
@@ -17,7 +17,8 @@ depends=('shared-mime-info'
'qt5-base'
'qt5-multimedia'
'qt5-tools'
- 'libxkbcommon-x11')
+ 'libxkbcommon-x11'
+ 'libfdk-aac')
makedepends=('git'
'cmake'
'python2')
@@ -55,6 +56,10 @@ build() {
# Flag to fix SDL exceptions occurring in some users' builds
CXXFLAGS+=" -I/usr/include/SDL2 -D_REENTRANT -pthread -lSDL2"
+ # Temporary workaround for the issue 3754:
+ # https://github.com/yuzu-emu/yuzu/issues/3754
+ sed -i 's:-Werror=conversion::' src/video_core/CMakeLists.txt
+
mkdir -p build
cd build
cmake .. \