summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgbcbooks2018-08-17 14:13:36 +0800
committergbcbooks2018-08-17 14:13:36 +0800
commit646be265d72c59cf57d6133ff507bf8abc5562c3 (patch)
treea665aca138d70b41efbaf3b658de045c265d19d1 /PKGBUILD
downloadaur-646be265d72c59cf57d6133ff507bf8abc5562c3.tar.gz
initial yy-wine-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc32e0086e40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+#
+# Maintainer: Goodman Leung<gbcbooksmj@gmail.com>
+#
+
+pkgname=yy-wine-1
+pkgver=1.0
+pkgrel=1
+pkgdesc="YY Voice from douwan run on wine"
+arch=('i686' 'x86_64')
+url="http://www.yy.com/"
+license=('unknow')
+groups=()
+depends=('p7zip' 'wine' 'xorg-xwininfo' 'xdotool')
+makedepends=()
+install=
+changelog=
+_mirror="http://yydl.duowan.com"
+YYver=8.30.0.0
+#source=("$pkgname-$pkgver.tar.gz"
+# "${_mirror}/4/setup/YYSetup-${YYver}.${YYrel}-zh-CN.exe"
+# "run.sh")
+source=("ftp://ftp.icmp.eu.org/tools/${pkgname}-${pkgver}-${pkgrel}.tar.gz"
+ "${_mirror}/4/setup/YYSetup-${YYver}-zh-CN.exe"
+ "run.sh")
+md5sums=("03a803bc2e36b3e48a855f0bf96be1ef"
+ "dc0bcee0ab07845e3c0b4156c042d9cc"
+ "dab77123bed67a79d771fd718dea4be2")
+
+build() {
+ pushd ${srcdir}
+ msg "update shell infornamtion ..."
+ sed -i "s/PKGNAME/${pkgname}/" run.sh
+ sed -i "s/APPVERSION/${YYver}/" run.sh
+ sed -i "s/PKGNAME/${pkgname}/" usr/share/applications/YY_Voice.desktop
+ sed -i "s/Name=/Name=1/" usr/share/applications/YY_Voice.desktop
+ popd
+}
+
+package() {
+ pushd ${pkgdir}
+ msg "Preparing icons and startup entry..."
+ mkdir -p usr/share
+ cp -r ${srcdir}/usr/share/* usr/share/
+ msg "Copying start script to opt/${pkgname} ..."
+ mkdir -p opt/${pkgname}
+ cp ${srcdir}/{files.7z,run.sh,YYSetup-${YYver}-zh-CN.exe} -i opt/${pkgname}
+ chmod +x opt/${pkgname}/run.sh
+ popd
+}