summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIdares2015-08-07 15:51:01 +0200
committerIdares2015-08-07 15:51:01 +0200
commitec2f44c2edebf76f7e8d92fae9708616b9a9078d (patch)
tree3ab2b283053165696aa3479deb87a397b2bbf136 /PKGBUILD
downloadaur-ec2f44c2edebf76f7e8d92fae9708616b9a9078d.tar.gz
Initial import.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c688cf0c5543
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Idares <idares at seznam dot cz>
+# Contributor: Enrico Morelli <morelli@cerm.unifi.it>
+# Contributor: Vadym Abramchuk <abramm@gmail.com>
+# Contributor: karol_007 <karol.blazewicz@gmail.com>
+
+pkgname=zabbix-agent
+pkgver=2.4.5
+pkgrel=1
+pkgdesc="Software designed for monitoring availability and performance of IT infrastructure components"
+arch=('i686' 'x86_64')
+url="http://www.zabbix.com"
+license=('GPL')
+backup=('etc/zabbix/zabbix_agent.conf'
+ 'etc/zabbix/zabbix_agentd.conf'
+ )
+install="zabbix-agent.install"
+source=("http://downloads.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/$pkgver/zabbix-$pkgver.tar.gz"
+ "zabbix-agent.install"
+ "zabbix-agentd.service"
+ "zabbix-agentd.tmpfiles"
+ )
+
+build() {
+ cd $srcdir/zabbix-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc/zabbix \
+ --with-libcurl \
+ --enable-agent
+ make
+}
+
+package() {
+ cd $srcdir/zabbix-$pkgver
+ make DESTDIR=$pkgdir install
+
+ install -d -m0750 $pkgdir/var/log/zabbix
+
+ install -D -m0644 $srcdir/zabbix-agentd.service $pkgdir/usr/lib/systemd/system/zabbix-agentd.service
+
+ # change pid file location
+ sed -i 's:# PidFile=.*:PidFile=/run/zabbix/zabbix_agentd.pid:' $pkgdir/etc/zabbix/zabbix_agentd.conf
+ # change log file location
+ sed -i 's:^LogFile=.*:LogFile=/var/log/zabbix/zabbix_agentd.log:' $pkgdir/etc/zabbix/zabbix_agentd.conf
+
+ # tmpfile
+ install -D -m 0644 $srcdir/zabbix-agentd.tmpfiles $pkgdir/usr/lib/tmpfiles.d/zabbix-agentd.conf
+}
+
+md5sums=('a82eb0d55d3ca947e10a4a55238f4388'
+ '519372592b66392255bfbf24e9469748'
+ 'd7ef5c8a7a6352dabecb9105da63fc84'
+ '9ce692356b4ac0a71595ce55fe3b44c1')
+sha1sums=('4e5ed20341b7178a032fc131960eafd7683610f0'
+ 'dcd2331be84f7b795087c8427f5c92837f2cf4ff'
+ 'acfe6a783cad8f28e7f23a65189af9a7d22bb540'
+ '8926befcb944732fd59a34c89b569d3fbef1ca9d')