summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIdares2015-08-07 15:54:10 +0200
committerIdares2015-08-07 15:54:10 +0200
commitcd8b630c0c11410f617de230f446f005f868f274 (patch)
tree7ba2dbce21389afd29770511856ea5abc087e5ea /PKGBUILD
downloadaur-cd8b630c0c11410f617de230f446f005f868f274.tar.gz
Initial import.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD96
1 files changed, 96 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6890520fcee2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,96 @@
+# Maintainer: Idares <idares at seznam dot cz>
+# Contributor: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+# Contributor: Enrico Morelli <morelli@cerm.unifi.it>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=zabbix-server
+pkgver=2.4.5
+pkgrel=1
+pkgdesc="Software designed for monitoring availability and performance of IT infrastructure components"
+arch=('i686' 'x86_64')
+url="http://www.zabbix.com"
+license=('GPL')
+depends=('apache' 'postgresql' 'php' 'php-pgsql' 'php-gd' 'fping' 'net-snmp' 'curl' 'iksemel' 'libxml2')
+backup=('etc/zabbix/zabbix_server.conf')
+install='zabbix-server.install'
+options=('emptydirs')
+source=("http://downloads.sourceforge.net/sourceforge/zabbix/zabbix-$pkgver.tar.gz"
+ 'zabbix-server.install'
+ 'zabbix-server.service'
+ 'zabbix-server.tmpfiles'
+ )
+
+_HTMLPATH='usr/share/webapps/zabbix'
+
+build() {
+ cd "$srcdir/zabbix-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --enable-server \
+ --with-net-snmp \
+ --with-jabber \
+ --with-libcurl \
+ --with-postgresql \
+ --with-libxml2 \
+ --sysconfdir=/etc/zabbix
+
+ make
+}
+
+package() {
+ cd "$srcdir/zabbix-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+
+ # Create data dirs required
+ install -d -m0750 $pkgdir/var/log/zabbix
+
+ # database schema
+ _DBSCHEMADIR="$pkgdir/etc/zabbix/database/postgresql"
+ mkdir -p $_DBSCHEMADIR
+ for _SQLFILE in {schema,data,images}.sql; do
+ install -D -m 0444 database/postgresql/$_SQLFILE $_DBSCHEMADIR/$_SQLFILE
+ done
+
+ # frontends (user:group = root:apache)
+ mkdir -p $pkgdir/$_HTMLPATH/
+ cp -r frontends/php/* $pkgdir/$_HTMLPATH/
+ chown -R http:http $pkgdir/$_HTMLPATH/
+ chmod -R u=rwX,g=rX,o= $pkgdir/$_HTMLPATH/
+
+ # default configuration files
+ install -D -m 0640 conf/zabbix_server.conf $pkgdir/etc/zabbix/zabbix_server.conf
+
+ # change pid file location
+ sed -i 's:# PidFile=.*:PidFile=/run/zabbix/zabbix_server.pid:' $pkgdir/etc/zabbix/zabbix_server.conf
+ # change log file location
+ sed -i 's:^LogFile=.*:LogFile=/var/log/zabbix/zabbix_server.log:' $pkgdir/etc/zabbix/zabbix_server.conf
+
+ # service file
+ install -D -m 0644 $srcdir/zabbix-server.service $pkgdir/usr/lib/systemd/system/zabbix-server.service
+
+ # tmpfile
+ install -D -m 0644 $srcdir/zabbix-server.tmpfiles $pkgdir/usr/lib/tmpfiles.d/zabbix-server.conf
+}
+
+md5sums=('a82eb0d55d3ca947e10a4a55238f4388'
+ '9b9f8575c1f43e5c993c83a37f4580dc'
+ '7200c01662be3a1d364c280ff2a818ac'
+ '9ce692356b4ac0a71595ce55fe3b44c1')
+sha1sums=('4e5ed20341b7178a032fc131960eafd7683610f0'
+ 'a645c438874928a78f40b7f31e10a69a32d8779c'
+ '7db689838d1f7985b75f91fb319227c3211bab7d'
+ '8926befcb944732fd59a34c89b569d3fbef1ca9d')
+