summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjohnnybash2019-05-10 19:32:34 +0200
committerjohnnybash2019-05-10 19:32:34 +0200
commitc181ef20b7d7271bf6643bdc8736ec7e8fe7ee34 (patch)
treea47b26a52b259aac428fe062f1da98d998c5988e /PKGBUILD
downloadaur-c181ef20b7d7271bf6643bdc8736ec7e8fe7ee34.tar.gz
Initial Import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b41cf00c196
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: johnnybash <georgpfahler at wachenzell dot org>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Joris Steyn <jorissteyn@gmail.com>
+# Contributor: fnord0 <fnord0 AT riseup DOT net>
+
+pkgname=zaproxy-weekly
+pkgver=2019_05_07
+pkgrel=1
+pkgdesc='Integrated penetration testing tool for finding vulnerabilities in web applications, weekly Pre-release'
+conflicts=('zaproxy')
+url='https://github.com/zaproxy/zaproxy'
+arch=('any')
+license=('Apache')
+depends=('java-runtime' 'ttf-font')
+source=(ZAP_WEEKLY_D-${pkgver//_/-}.zip::https://github.com/zaproxy/zaproxy/releases/download/w${pkgver//_/-}/ZAP_WEEKLY_D-${pkgver//_/-}.zip)
+sha512sums=('073aa780bca2a552df375fbde34e56d9ee6f231f25a7cb4758d3e4a6fb03673ef80d5ac02a1155b414776c80762ff60ef991d45898cfe38bee6c4718caa9d529')
+
+prepare() {
+ cd ZAP_D-${pkgver//_/-}
+ cat > zaproxy <<EOF
+#!/bin/sh
+cd /usr/share/zaproxy
+./zap.sh
+cd -
+EOF
+}
+
+package() {
+ cd ZAP_D-${pkgver//_/-}
+ rm plugin/*macos* plugin/*windows*
+ install -d "${pkgdir}/usr/share/zaproxy"
+ cp -pR . "${pkgdir}/usr/share/zaproxy"
+ install -Dm 755 zaproxy "${pkgdir}/usr/bin/zaproxy"
+}
+
+# vim: ts=2 sw=2 et: