summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoritz Lipp2020-03-27 18:39:41 +0100
committerMoritz Lipp2020-03-27 18:39:41 +0100
commit8d87a381d1a7830ffc757082b26cc421fb4daea4 (patch)
treeb0bc770a8598dfbcd82999d8a4e78773ec6a3e5d /PKGBUILD
parentd6f53b881ff0211a5ee524ad054feceee90302f0 (diff)
downloadaur-8d87a381d1a7830ffc757082b26cc421fb4daea4.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c85764a45176..547b8ce9f3b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Moritz Lipp <mlq@pwmt.org>
pkgname=zathura-git
-pkgver=0.3.8.135.ga647b92
+pkgver=0.4.5.28.g3b4540f
pkgrel=1
pkgdesc="a document viewer"
arch=('i686' 'x86_64')
@@ -9,6 +9,8 @@ url="http://pwmt.org/projects/zathura"
license=('custom')
depends=('girara-git' 'gtk3>=3.10' 'cairo>=1.8.8')
makedepends=('git' 'python-sphinx' 'intltool' 'meson')
+optdepends=('fish', 'bash-completion')
+checkdepends=('check')
conflicts=('zathura')
provides=('zathura')
source=('zathura::git+https://git.pwmt.org/pwmt/zathura.git#branch=develop')
@@ -32,6 +34,11 @@ build() {
ninja
}
+check() {
+ cd build
+ ninja test
+}
+
package() {
cd build
DESTDIR="$pkgdir/" ninja install