aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreoli3n2020-05-11 12:01:08 +0200
committereoli3n2020-05-11 12:01:08 +0200
commit51b4f16186351174d0dcd43504e2d62a454cb8e0 (patch)
tree4446c75d6aa1e781b8cbd3fd39681b9266b10b93 /PKGBUILD
downloadaur-51b4f16186351174d0dcd43504e2d62a454cb8e0.tar.gz
added first files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..438ce562b734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jonathan Kirszling <jkirsz@gmail.com>
+# Info: https://github.com/johnramsden/zectl/issues/16
+pkgname=zectl-pacman-hook
+pkgrel=1
+pkgver=0.1.0
+pkgdesc="Create and prune zectl boot environments before any pacman command"
+arch=('any')
+url="https://github.com/eoli3n/$pkgname"
+license=('UNLICENSE')
+depends=('zectl')
+install="INSTALL"
+source=("10-zectl-pre.hook"
+ "zectl-prune"
+ "UNLICENSE")
+sha256sums=("de9a144e6cda1911395b6491f2e83af0089a72e9eab92199d489b29919d76c2f"
+"b38b0b2fca33ce64d5c1e713feb3bd7d3a0e85fa8d5c4c5220edefc2a63440da"
+"d3c4f1607c9488b22732511b83e6f6173d82499c0678c899666ca12c36517f72")
+
+package() {
+ install -Dm644 '10-zectl-pre.hook' "${pkgdir}/usr/share/libalpm/hooks/10-zectl-pre.hook"
+ install -Dm755 'zectl-prune' "${pkgdir}/usr/share/libalpm/scripts/zectl-prune"
+ install -Dm644 'UNLICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/UNLICENSE"
+}