summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Ramsden2018-11-16 19:38:53 -0800
committerJohn Ramsden2018-11-16 19:38:53 -0800
commit398639184990a3eb9557dc975c0236da44d7b249 (patch)
treeed78856974cdf9a714fc00ef748f08911209f304 /PKGBUILD
downloadaur-398639184990a3eb9557dc975c0236da44d7b249.tar.gz
Add initial PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..051e8a4cb7cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: John Ramsden <johnramsden [at] riseup [dot] net>
+
+pkgname=zedenv-grub
+pkgver=0.1.2
+_version_suffix="alpha"
+pkgrel=1
+pkgdesc="zedenv plugin for GRUB (ALPHA)"
+arch=('any')
+url="http://github.com/johnramsden/zedenv-grub"
+license=('BSD' 'custom:BSD 3 clause')
+depends=('zfs' 'python' 'python-setuptools' 'python-click' 'python-pyzfscmds')
+makedepends=('git' 'python-pip')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/johnramsden/${pkgname}/archive/v${pkgver}-${_version_suffix}.tar.gz")
+md5sums=('63c83dac64d7ebc234e0409b742c27ed')
+conflicts=('zedenv-grub-git')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}-${_version_suffix}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}-${_version_suffix}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ install -d "${pkgdir}/usr/share/license/${pkgname}"
+ install -m 755 "LICENSE" "${pkgdir}/usr/share/license/${pkgname}/LICENSE"
+}