summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Skelsey2020-05-14 10:51:05 +0200
committerNick Skelsey2020-05-14 10:51:05 +0200
commit3da0188f0a67dc2494edd3e46abc9bf41bbf2f37 (patch)
tree413fc6edea7ad28a6e0bbedbf2344d2b1e6112f7 /PKGBUILD
parent9391cfe211aab31a93d8945fae824d9a40fab07d (diff)
downloadaur-3da0188f0a67dc2494edd3e46abc9bf41bbf2f37.tar.gz
Bump version, use tarball, change unpack targets
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75a0e1e851d5..74d0af678480 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
-# Maintainer: Nick Skelsey <nskelsey+zz@gmail.com>
+# Maintainer: Nick Skelsey <nskelsey@gmail.com>
pkgname=zeek
-pkgver=3.1.0.dev465.gf3e5728bc
-pkgrel=3
+pkgver=3.1.3
+pkgrel=1
pkgdesc="A network analysis framework"
arch=('x86_64')
url="https://zeek.org"
license=('BSD')
depends=("zlib" "libpcap" "bash" "libmaxminddb")
makedepends=("cmake" "swig" "bison" "flex" "python3" "openssl" "libpcap" "bash" "geoip" "zlib" "gperftools" "shadow")
-source=("git+https://github.com/zeek/zeek")
-md5sums=("SKIP")
+source=("https://github.com/zeek/zeek/releases/download/v3.1.3/zeek-3.1.3.tar.gz")
+sha256sums=("d7bf24615c4c0af2435c99c9fb8c9c0f0ecdce375e184ba7f63b715ae5900a61")
-pkgver() {
- cd "$srcdir/zeek"
- git describe --always | sed 's/^v//;s/dev-/dev/;s/-/./g'
-}
build() {
- cd "$srcdir/zeek"
- git submodule update --init --recursive
- ./configure --prefix=/opt/zeek --binary-package --enable-static-binpac --disable-python
+ cd "$srcdir/zeek-$pkgver"
+ ./configure --prefix=/usr/ --binary-package --enable-static-binpac --disable-python --disable-zeekctl --disable-broker-tests --libdir=/usr/lib/zeek
make
}
+
package() {
- cd "$srcdir/zeek"
+ cd "$srcdir/zeek-$pkgver"
make DESTDIR="$pkgdir/" install
}