summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-04-18 21:05:22 -0400
committerJean Lucas2019-04-18 21:05:22 -0400
commit5b03b42b7d96cf6c21146c3a6e157db43e63f665 (patch)
treed52c5e8fa0e32aca128367155e509d1f0b06b0e2 /PKGBUILD
parentdd063799e474cfc8503a7b6245df60489ccc2cd9 (diff)
downloadaur-5b03b42b7d96cf6c21146c3a6e157db43e63f665.tar.gz
Quit if API details are not set
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0b277ecab52..234d8d7cf01a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zerotwo
pkgver=0.6.2+beta
-pkgrel=2
+pkgrel=3
pkgdesc='AniList anime tracker written with Electron & Vue.js'
arch=(i686 x86_64)
url=https://www.zerotwo.org
@@ -18,8 +18,13 @@ build() {
cd zerotwo-${pkgver/+/-}
# You must generate an API client ID and secret on AniList in order to use the login function
+ # Generate them at https://anilist.co/settings/developer
_api_id=
_api_secret=
+ if [ -z $_api_id ] || [ -z $_api_secret ] ; then
+ echo "AniList API client ID and secret must be manually set for ZeroTwo to function properly. Quitting..."
+ exit
+ fi
echo -e CLIENT_ID=${_api_id}'\n'CLIENT_SECRET=${_api_secret} > .env
npm i